首页 » Youtube » 解决you-get安装中的一些小问题(升级pip,安装报错怎么办)

解决you-get安装中的一些小问题(升级pip,安装报错怎么办)

 

提示 pip版本过低

"You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip’ command. “

You-get 是需要python支持的,如果在win的cmd中安装you-get 出现上面的情况,最好还是升级一下pip版本。如果你是长期下载大量视频的话,保持you-get 的update 是很有必要的。步骤十分简单,就是几个命令的事。

pip版本升级命令:python -m pip install -U pip, python会自动下载新版安装

pip 自动更新中

完成后,如图会出现成功Successfully installed字样。

成功更新pip

如果出现类似以下的红字提示:大部份情况是用户权限不够,请检查你的帐户是否管理员(win):

Collecting pip
Using cached pip-8.1.1-py2.py3-none-any.whl
Installing collected packages: pip
Found existing installation: pip 7.1.2
Uninstalling pip-7.1.2:
Exception:
Traceback (most recent call last):

Win7来说,一般都是标准用户引起的错误,就是提升帐户权限,把标准用户改成管理员,问题基本能修复,其他问题当然是具体问题具体分析。

原文链接:解决you-get安装中的一些小问题(升级pip,安装报错怎么办),转载请注明来源!

1